# Table of Contents

1. **INTRODUCTION** ................................................................................................................................. 1
2. **TOPOLOGY TOLERANCE** .................................................................................................................... 1
3. **TOPOLOGY VERIFICATION LOGIC DESCRIPTIONS** ................................................................. 2
   2.10.1.1 LINES DO NOT INTERSECT ........................................................................................................... 2
   2.10.1.2 LINES DO NOT OVERLAP .............................................................................................................. 3
   2.10.1.3 LINE MUST NOT SELF-OVERLAP ................................................................................................... 4
   2.10.1.4 LINE MUST BE A SINGLE PART ..................................................................................................... 5
   2.10.1.5 LINE MUST NOT OVERLAP WITH LINE IN ANOTHER FEATURE CLASS ............................................ 6
   2.10.1.6 POLYGON FEATURECLASS MUST NOT HAVE GAPS ...................................................................... 7
   2.10.1.7 POLYGONS MUST NOT OVERLAP .................................................................................................. 8
   2.10.1.8 LINE MUST NOT HAVE PSEUDO-NODES (THIS CHECK IS CURRENTLY TURNED OFF) ........... 9
   2.10.1.9 BOUNDARY MUST BE COVERED BY LINE FEATURECLASS ......................................................... 10
   2.10.1.10 POLY FEATURECLASS MUST COVER ANOTHER POLY FEATURECLASS ................................. 11
   2.10.1.11 LINE FEATURECLASS MUST BE COVERED BY BOUNDARY OF POLY FEATURECLASS .................. 12
4. **LOCATING TOPOLOGY ERRORS** ............................................................................................................. 13
   **STEP 1:** IMPORT YOUR SHAPEFILES INTO A NEW PGDB ................................................................. 13
   **STEP 2:** CREATE A NEW TOPOLOGY AND ADD TOPOLOGY RULES .................................................... 14
   **STEP 3:** VIEW TOPOLOGY ERRORS IN ArcMap .................................................................................. 16
1. Introduction

The new automated DFIRM QAQC application, DFIRM Verification Tool (DVT), was integrated into the MIP and launched in December 2009. With the introduction of DVT new topological verifications were added to the QAQC process. There are 10 new topological verifications currently active in DVT (9 errors and 1 warning) that utilize ESRI topology rules.

This document provides the logical description of these new topological verifications. Each verification description will include the following:

- Reference to the requirement
- The DFIRM layers and ESRI Topology Rule used by the verification
- Logic Description
- QC Category
- Error Type
- Error Message

The format of these verification descriptions is similar to the format used by the FEMA DFIRM Verification Check Standard which details the logic for the existing DFIRM verifications.

In addition to the verification descriptions a troubleshooting section has been added which provides a suggested process for locating topology errors found by DVT. It provides step-by-step guidance that reproduces the same results as DVT within ESRI’s ArcMap application. This process includes steps to convert Shapefile data to PGDB data, create a topology and add ESRI topology rules, validate topology, and view topology errors within ArcMap.

The scope of this document is limited to the new topology verifications. All other verifications performed by DVT have existing logic descriptions found in the FEMA DFIRM Verification Check Standard document.

2. Topology Tolerance

The tolerance used for topology verifications in DVT is configurable. The current tolerance setting uses the default cluster tolerance of the PGDB. For a Shapefile submission the default cluster tolerance will be 0.001 meters or 0.003280833333333 feet which are the ESRI default values for XY tolerance in a new dataset within a PGDB.
3. Topology Verification Logic Descriptions

2.10.1.1 Lines do not intersect

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

**Rule Applied To:** S_BFE table

**Statement:**
If
  o Lines do not cross or overlap any part of another line within the same feature class or subtype.
Then
  o Correct – move to next check.
Else
  o An error will be returned.

**QC Category:** Spatial Check
**Error Type:** “Error”
**Error Message:** “Error 1401: The following tables contain lines which intersect:”
2.10.1.2 Lines do not overlap

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

Rule Applied To: \textit{S\_BFE table}

Statement:

If
  \begin{itemize}
  \item Lines do not overlap any part of another line within a feature class or subtype.
  \item Lines can touch, intersect, and overlap themselves.
  \end{itemize}

Then
  \begin{itemize}
  \item Correct – move to next check.
  \end{itemize}

Else
  \begin{itemize}
  \item An error will be returned.
  \end{itemize}

QC Category: Spatial Check
Error Type: “Error”
Error Message: “Error 1402: The following lines should not overlap:”
2.10.1.3 Line must not self-overlap

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

**Rule Applied To:**  
*S_BFE, S_CST_TSCT_LN, S_FLD_HAZ_LN, S_GEN_STRUCT, S_POL_LN and S_XS tables*

**Statement:**

If

- Lines do not overlap themselves within a feature class or subtype. Lines can touch, intersect, and overlap lines in another feature class or subtype.

Then

- Correct – move to next check.

Else

- An error will be returned.

**QC Category:** Spatial Check  
**Error Type:** “Error”  
**Error Message:** “Error 1403: The following lines should not self-overlap.”
2.10.1.4 Line must be a single part

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

Rule Applied To: S_BFE, S_CST_TSCT_LN, S_FLD_HAZ_LN, S_GEN_STRUCT and S_XS tables

Statement:

If
  o Lines within a feature class or subtype have only one part.
Then
  o Correct – move to next check.
Else
  o An error will be returned.

QC Category: Spatial Check
Error Type: “Error”
Error Message: “Error 1404: The following lines should be a single part:”
2.10.1.5 Line must not overlap with line in another feature class

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

Rule Applied To: $S_{BFE}$ and $S_{XS}$ tables

Statement:

If
  - Lines in one feature class or subtype do not overlap any part of another line in another feature class or subtype.
Then
  - Correct – move to next check.
Else
  - An error will be returned.

QC Category: Spatial Check
Error Type: “Error”
Error Message: “Error 1405: The following $S_{BFE}$ lines should not overlap with $S_{XS}$ lines”
2.10.1.6  Polygon FeatureClass must not have gaps

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

Rule Applied To: S_FLD_HAZ_AR, S_POL_AR and S_FIRM_PAN tables

Statement:

If
  o Polygons do not have a void between them within a feature class or subtype.
Then
  o Correct – move to next check.
Else
  o A warning will be returned.

QC Category: Spatial Check
Error Type: “Warning”
Error Message: “Warning 1406: The following polygon layers may have gaps”
2.10.1.7 Polygons must not overlap

**Reference:** The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

**ESRI Topology Rule:**

```
Must not overlap

Polygons must not overlap within a feature class or subtype. Polygons can be disconnected or touch at a point or touch along an edge.

Use this rule to make sure that no polygon overlaps another polygon in the same feature class or subtype.

Polygon errors are created from areas where polygons overlap.
A voting district map cannot have any overlaps in its coverage.
```

**Rule Applied To:** S_FLD_HAZ_AR, S_POL_AR and S_FIRM_PAN tables

**Statement:**

If

- Polygons do not overlap within a feature class or subtype. Polygons can be disconnected or touch at a point or touch along an edge.

Then

- Correct – move to next check.

Else

- An error will be returned.

**QC Category:** Spatial Check

**Error Type:** “Error”

**Error Message:** “Error 1407: The following polygons should not overlap:”
2.10.1.8 Line must not have pseudo-nodes (THIS CHECK IS CURRENTLY TURNED OFF)

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

Rule Applied To: S_FLD_HAZ_LN, S_POL_LN and S_PLSS_LN tables

Statement:

If
  ○ The end of a line does not touch the end of only one other line within a feature class or subtype. The end of a line can touch any part of itself.

Then
  ○ Correct – move to next check.

Else
  ○ An error will be returned.

QC Category: Spatial Check

Error Type: “Error”

Error Message: “Error 1408: The following lines should not have pseudo-nodes”
2.10.1.9 Boundary must be covered by Line FeatureClass

**Reference:** The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

**ESRI Topology Rule:**

**Rule Applied To:** S_FLD_HAZ_AR boundary covered by S_FLD_HAZ_LN and S_POL_AR boundary covered by S_POL_LN

**Statement:**

If
  o Polygon boundaries in one feature class or subtype are covered by the lines of another feature class or subtype.
Then
  o Correct – move to next check.
Else
  o An error will be returned.

**QC Category:** Spatial Check

**Error Type:** “Error”

**Error Message:** “Error 1409: The boundary of the following polygons should be covered by the corresponding line feature. S_FLD_HAZ_AR boundary must be covered by S_FLD_HAZ_LN and S_POL_AR boundary must be covered by S_POL_LN”
2.10.1.10 Poly FeatureClass must cover another Poly FeatureClass

Reference: The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

ESRI Topology Rule:

Rule Applied To: S_FLD_HAZ_AR and S_POL_AR

Statement:

If
  o S_FLD_HAZ_AR and S_POL_AR polygons cover each other.
Then
  o Correct – move to next check.
Else
  o An error will be returned.

QC Category: Spatial Check

Error Type: “Error”

Error Message: “Error 1410: The following S_FLD_HAZ_AR polygons must be covered by S_POL_AR polygons”
2.10.1.11 Line FeatureClass must be covered by boundary of Poly FeatureClass

**Reference:** The verification is based on page 15-21, section 4.2, “Final Requirements Document DFIRM Verification Tool (DVT) Release 1”. Also, the check function is based on ESRI ArcGIS Geodatabase Topology Rules.

**ESRI Topology Rule:**

**Rule Applied To:**  
- **S_FLD_HAZ_LN must be covered by boundary of S_FLD_HAZ_AR**
- **S_POL_LN must be covered by boundary of S_POL_AR**

**Statement:**

If  
- Lines in one feature class or subtype are covered by the boundaries of polygons in another feature class or subtype.

Then  
- Correct – move to next check.

Else  
- An error will be returned.

**QC Category:** Spatial Check  
**Error Type:** “Error”  
**Error Message:** “Error 1411: The following lines must be covered by the boundary of their corresponding polygons.  S_FLD_HAZ_LN must be covered by S_FLD_HAZ_AR and S_POL_LN must be covered by S_POL_AR”
4. Locating Topology Errors

The DVT error reports will provide the tables, and in some cases the record IDs, for each topology error that was detected during topology validation. It can be difficult to locate the error for very complex features. The following process can be used to find the same topological errors as DVT within ESRI’s ArcMap application:

**Step 1: Import your Shapefiles into a new PGDB**

- Create a new PGDB within ArcCatalog. Select File ➔ New ➔ Personal Geodatabase
- Open the new PGDB and add a Feature Dataset. Select File ➔ New ➔ Feature Dataset. Select the correct projected coordinate system for your study area. Leave the tolerance settings at their default values. The default tolerance depends on the units used for the Dataset. A dataset with meters as the unit will have a default tolerance of 0.001m. A dataset with feet as the unit will have a default tolerance of 0.003280833333333 feet. See the screenshot below for more details.

<table>
<thead>
<tr>
<th>New Feature Dataset</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>XY Tolerance</strong></td>
</tr>
<tr>
<td>The XY tolerance is the minimum distance between coordinates before they are considered equal. The XY tolerance is used when evaluating relationships between features.</td>
</tr>
<tr>
<td>0.0032808333333333</td>
</tr>
<tr>
<td><strong>Z Tolerance</strong></td>
</tr>
<tr>
<td>0.001</td>
</tr>
<tr>
<td><strong>M Tolerance</strong></td>
</tr>
<tr>
<td>0.001</td>
</tr>
</tbody>
</table>

- Right Click on the new dataset and select Import ➔ Feature Class (multiple)
- Select the shapefiles to be imported and click OK to add them to your PGDB.
Step 2: Create a new topology and add topology rules

- Right click on the dataset and select New → Topology.
- Name the new topology and leave the cluster tolerance at the default value.
• Select the features used in the topology rule you want to validate. In our example we use Error 1410 so S_FLD_HAZ_AR and S_POL_AR are the features used.

• Leave the rank settings at the default values (all features should have the same rank).

• Add the desired topology rule based on the definitions in this document. For our example, 2.10.1.10 (Error 1410) uses the rule “Must Cover Each Other”.

Add Rule

Features of feature class:

<table>
<thead>
<tr>
<th>S_Fld_Haz_Ar</th>
</tr>
</thead>
</table>

Rule:

Must Cover Each Other

Feature class:

<table>
<thead>
<tr>
<th>S_Pol_Ar</th>
</tr>
</thead>
</table>

Rule Description:

The area features of one layer and the area features of another layer must cover each other.

Any area where the features of either layer do not cover the other layer is an error.

Show Errors

OK

Cancel
Click OK and finish creating the topology. When it asks you to validate your topology click yes.

**Step 3: View Topology Errors in ArcMap**

Open ArcMap and add the topology you just created. Click yes when it asks to add the features that participate in the topology.

Now all of the spotted topology errors will be highlighted. Sometimes these errors are very small and difficult to spot when viewed at the full extent. If the error is not obvious, you can use the Topology Error Inspector.

To use the error inspector, you must first be in editing mode. Click on Editor → Start Editing.

You must also have the topology toolbar enabled. Click View → Toolbars → Topology. You should now see the topology toolbar. The far right button will bring up the error inspector:
In the error inspector window you can select the topology rule you want to view errors for and click search now to bring up a list of errors.

You can find one of these errors by right clicking on the error and selecting Zoom To. You may need to zoom in even further to make the error clear.